+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jan 2009
    Posts
    1

    USB DEVICE not detected - Windows XP SP3

    Hi,
    I use Windows XP Service Pack 3. And my laptop has a USB 2.0 port.
    Ideally, any USB/removable disk should be detected without the driver. But whenever i connect an external hard disk, the system starts serching/installing the driver but fails to do so. So it doesn't detect the external drive. For some of them I installed the driver but for some others i could'nt get. Is there any setting in the Windows/ or should i have some files in the C:\WINDOWS\System32\Driver for it to detect all my external drives as i plug in?

    Regards
    Heshesspee

  2. #2
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Location
    Northern New Jersey
    Posts
    2,724
    Shoot to the last post on this page:

    USB mass storage driver? - Windows XP Support

    Good luck.
    MCSE, MCP and nut job

  3. #3
    Ultimate Member bigBonehead's Avatar
    Join Date
    Dec 2008
    Location
    East Chamunga
    Posts
    2,362

  4. #4
    Junior Member
    Join Date
    Jun 2011
    Posts
    1

    There is a way

    This is being posted so much later,but maybe it will help someone. Go to each of the USB ports in device manager, and update the drivers. Don't let windows find them, use the I will selct option. There will probably suddenly be two drivers to choose from, choose the alternate one. Try it with one of the ports, and then test it out. Then follow suit with the rest. It does work.

  5. #5
    Junior Member
    Join Date
    Mar 2012
    Posts
    1

    Solution

    USB Drivers for Windows XP, Vista & Windows 7

    Provided you have purchased your laptop after 2004, this Should work.

Quick Reply Quick Reply

If you are already a member, please login above.

What is 10 and 5 added together?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: December 31st, 2007, 09:07 AM
  2. Video Capture Device Not Detected (VCR)
    By AG124 in forum Technical Support
    Replies: 4
    Last Post: May 6th, 2006, 02:41 PM
  3. Replies: 10
    Last Post: October 19th, 2005, 08:24 AM
  4. No sound device detected ?
    By Ron Pace in forum Multimedia and Audio
    Replies: 5
    Last Post: April 6th, 2005, 01:24 AM
  5. Replies: 3
    Last Post: December 30th, 2003, 02:14 AM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc