+ Reply to Thread
Results 1 to 13 of 13
  1. #1
    Junior Member
    Join Date
    Feb 2005
    Posts
    25

    Help me with KOTOR Yavin glitch

    First of all, I have Star wars: KOTOR for Xbox.

    My game has been fun and all, until I got to the yavin station.
    I walk through the doors, and when I go through the third door, the glitch begins.
    The whole screen goes black except for a dialogue at the bottome as if I just played
    a pazaak game and the dialogue is asking if I want to play again. It doesn't matter if I choose to
    play again or if I quit. Then the screen remains black. I can pull up the start menus.
    I can move around, hear the footsteps, confirm my movement with the map in the start menu,
    but the screen is all black.
    I've read some forums about this problem before but I've never actually seen a real answer to the problem. I've never heard about how to get around this problem.
    Should I delete it and then download it again?

    Thanks for your time

  2. #2
    Senior Member
    Join Date
    Jul 2003
    Location
    Minneapolis, MN
    Posts
    545
    Ny saying download it again are you sayign you have an illegal copy? Jeez the PC version is only $20 for crying out loud!!!
    ----------------------
    WindowsXP Home
    Asus A7N8X-X
    XP+2800
    768 Mb RAM
    120 Gb Maxtor HDD
    52/24/52 Samsund CD-RW
    Pioneer 106 DVD-RW

  3. #3
    Junior Member
    Join Date
    Feb 2005
    Posts
    25
    No I don't have no illegal copy!

    I got the XBOX version for my XBOX.

    Then I downloaded the Yavin content off of XBOX LIVE.

    Sorry, maybe I should have made that more clear.
    Should I download the Yavin Station downloadable content again?
    Last edited by spartank3b; April 10th, 2005 at 12:52 AM.

  4. #4

    Star Wars KOTOR - Yavin 4 glitch, workaround

    Testing--I have a workaround for this glitch, but I'm not sure I can post here.

  5. #5

    Star Wars KOTOR - Yavin 4 glitch, workaround

    I'm in the exact same situation as you: I have a legal disc of the Xbox KOTOR game, and in about 2004 I downloaded (again, legally) the Yavin 4 extra content from Xbox live. I played through the game several times over the years, and never saw this glitch until last night. I figured out a workaround--I'm no longer on Xbox live so re-downloading the extra content wasn't an option.

    I used a 2-person party (my main character + Mission), but the workaround should work with any 2 or 3-character party. I landed on the Yavin station (for about the 5th time, with plenty of coarse language as I tried to find a way around the glitch), exited the Ebon Hawk, and took only Mission with me.

    Once the load screen's finished, you and Mission are standing at one end of a long, straight hallway. Don't start running down the hall yet. Select the panel right next to you that lets you open the door leading back to the Ebon Hawk. Hit that panel, so that the door is open. Now go into solo mode (by pressing the Back button on your controller). Position your main character so that he/she is facing the open doorway to the Ebon Hawk (the blue icon indicating an area transition should show onscreen). Now switch to Mission. Run to the other end of the hallway, where the Rodian salesman is waiting in his shop. You have to open 2 doors to reach the door to the shop (the 3rd door).

    I don't think this matters, but before opening the 3rd door, I switched Mission's (stealth) cloaking on. Then I opened the door, and the glitch kicked in again. I exited the conversation as fast as possible (out of anger, naturally). Then I switched to my main character, who was still by the doorway to the Ebon Hawk. Then I hit the Back button and exited solo mode, and waited for Mission to come to me (I used the map to track her fairly slow progress). Once she was close to me, I used the left thumbstick to move my main character forward and into the Ebon Hawk.

    After that, when I went back to the Rodian salesman, it was glitchy for a second or two at first, then it was okay--he starts talking to you through a video intercom, then lets you into his shop.

  6. #6
    Member JRB3's Avatar
    Join Date
    Dec 2005
    Location
    Location, Location
    Posts
    414
    All that effort then you finally realize the problem is nearly four years old :-)

    But heck maybe Spartank3b will come back he's a very active member hey was online just last august 2006 :-)

    Still if it solves the problem its all good i guess, Welcome to TIMO :-)
    "I hope you leave enough room for my fist because I'm going to ram it into your stomach and break your god-damn spine! "

  7. #7
    Ultimate Member cksboy15's Avatar
    Join Date
    Nov 2008
    Location
    Columbus, Ohio, Unit
    Posts
    1,426
    I had that problem on the PC version (when the game first came out) and I got an update that fixed it. Funny that the same glitch appears on the downloadable xbox version.

  8. #8
    Yeah yeah I knew it was 4yrs old, but I couldn't find a solution to the problem. I'd have thought someone would've posted a fix by now, or better yet a patch would be available on Xbox Live.

  9. #9

    Smile Star Wars KOTOR - Yavin 4 glitch, workaround

    Thanks for the workaround. I'd also been to Yavin4 lots of times with no problems, then the same thing happened to me. The difference is that when the screen went blank and the pazaak dialogue ensued, both Mission and the main character ended up at the same end of the hallway (the merchant's end). Thankfully, it's just one straight hallway so I used the map to navigate back to the Hawk with the screen totally blank. Aargh.

    It probably took you a long time to figure it out, but from the time I discovered the bug, tried a few things, googled and found your workaround and executed it, it took me about an hour all told. So you really saved a lot of time!

    Thanks!

  10. #10

    Cool Star Wars KOTOR - Yavin 4 glitch, workaround

    BTW, I think the glitch is triggered when you completely defeat the pazaak player on dantooine before the first time you go to yavin 4. By completely defeat I mean beat him enough times that he runs out of money then beat him one last time for his wagered cards.

    If you go to yavin4 before completely defeating the dantooine pazaak guy, you won't have any problems entering yavin4 but the merchant there will respond to the first thing you say as if he had just beaten you at a pazaak game.


  11. #11
    That makes sense--I think you're right, that is how it's triggered.

  12. #12
    Ive been having this same problem on the PC version, but on the door to upper city taris from the apartments.

  13. #13
    Junior Member
    Join Date
    Sep 2014
    Posts
    0
    I've just had this problem on the PC. After I exited the dialog with the black screen I accidentally hit auto save and the screen came back and no more bugs

Quick Reply Quick Reply

If you are already a member, please login above.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. KotOR 2
    By Creatures in forum General Gaming Discussion
    Replies: 13
    Last Post: July 8th, 2005, 09:44 PM
  2. Tell me about KOTOR
    By spartank3b in forum General Gaming Discussion
    Replies: 3
    Last Post: March 11th, 2005, 03:05 PM
  3. Kotor Ii
    By xelnanga in forum General Gaming Discussion
    Replies: 9
    Last Post: December 19th, 2004, 07:38 PM
  4. KOTOR
    By Whitehawk in forum General Gaming Discussion
    Replies: 3
    Last Post: February 7th, 2004, 06:46 PM
  5. KotOR
    By Optimus Prime in forum General Gaming Discussion
    Replies: 26
    Last Post: December 25th, 2003, 07:46 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc