+ Reply to Thread
Results 1 to 15 of 15
  1. #1
    Junior Member
    Join Date
    Sep 2009
    Posts
    8

    My 500GB External Hard Drive suddenly not working!!

    Hello! I'm hoping somebody might be able to help me... I'm at my wits end with this!!

    A few days ago, my USB External hard drive was working completely fine. Then I was shutting the computer down, and I clicked on the "Safely Remove Hardware" but it was saying it was unable to close. I tried it for a few more minutes, and it still wouldn't close. So I just unplugged it. *I do that a few times, if the computer says it can't close down, and it always works again!*

    So tonight, I decided to use my hard drive again, and I plug it in, and it doesn't work. Ok, so I shut the computer down and reboot it. That always works. It didn't this time.

    So I've been on a few websites/forums trying to find out what to do, and I have tried EVERYTHING I can think of and what others have said to do. I've delete the USB ports, shut down the computer, plugged the USB hard drive in, and rebooted. And all it did was reinstall the USB ports. I've even looked to see if there is a problem with the USB ports, nope, says it's all working fine.

    I've tried downloading a program to see if the driver needs to be updated. Nope. Updated.

    I've tried doing a system restore to when it was working previously. And that still doesn't work!

    I've tried plugging in something else by USB and that works. Plugged the hard drive into all the USB ports I have

    I've looked in the error logging to about the time it had happened and it there were a lot of errors in a matter of a minutes, which said "
    An error was detected on device \Device\Harddisk1\D during a paging operation." and "
    The system failed to flush data to the transaction log. Corruption may occur."

    Now that's scared me. I just surely hope I haven't corrupted this hard drive because it wasn't closing down and taking it out!!

    Does anybody have any helpful ideas on what to do??

    Here's any details you may need:
    OS: Windows XP SP2
    It's a Toshiba, about 3yrs old with 4 USB ports with a 1.40GHz, and 960MB RAM.
    The Hard Drive is a Philips 500GB SPE3051CC/00

    Thanks in advance,
    chimp1984

  2. #2
    Ultimate Member bigBonehead's Avatar
    Join Date
    Dec 2008
    Location
    East Chamunga
    Posts
    2,364
    I spose my first question would be why this: "I clicked on the "Safely Remove Hardware"" What were you trying to uninstall?
    The USB HD? Have you got the Install disc for the Philips? If so, run that and see what happens...
    ◄ it is what it is ►

  3. #3
    Junior Member
    Join Date
    Sep 2009
    Posts
    8

    Unhappy

    I clicked on "Safely Remove Hardware" because that's what you normally do when you have a USB hardware plugged into a USB port.

    My wife doesn't remember if it came with a CD, or if it's plug and play. Tried Philips website for software, they don't have one for my model. Tried drivers.com, all that did was tell me my driver for the hard drive was up to date.

    Somebody at my wife's work, suggested a delayed virus?? I downloaded a 22GB file directly to the hard drive. Used it for a week, and was working up to when I unplugged it, then wasn't working a few days later. Is that possible?

    I haven't tried plugging into another computer to see if it works, but my mom is coming up in a few weeks, and I will try then. If it does not work, what do you suggest?

    Thanks.

  4. #4
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    Oh, and it doesn't even show that there is anything plugged into the USB, like there usually is. No ping, no icon. Nothing. And it won't even show in "My Computer"

    Any help would be GREATLY appreciated! I use this hard drive, as a back up for all the other files on the laptop! And my wife is not too happy with me, now... :-S

    Thanks...

  5. #5
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    Another question, sorry. If it could be a virus on the external hard drive, how can you check for viruses on a hard drive that doesn't even show??

  6. #6
    Ultimate Member MD1032's Avatar
    Join Date
    Nov 2002
    Posts
    1,728
    While it's plugged in, go into device manager (Control Panel, System, Hardware Tab), and right click on the hard drive (might be under unknown devices...the yellow question mark), and just uninstall it. Unplug the drive, restart your computer, and plug it in again. This will give it a chance to completely reinitialize.

  7. #7
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    Nothing questionable is showing in the USB part of the Device Manager. I've checked all of them, and it says there is no problems. I've uninstalled them all before, whilst having the hard drive plugged in, and restarted, and it didn't work. Do you think uninstalling the "Plug and Play Software Device Enumerator" may work?

    This hard drive is not recognized at all. No ping, no icon saying it's been connected, and not showing in "My Computer" at all, so I've no idea what has happened to it.

    Thanks

  8. #8
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    I've tried that tip, again, right now. Just in case I missed something a few weeks ago, or did something wrong. I didn't see anything with a question mark next to it, so I uninstalled ALL the USB's *about 6* with the Hard Drive plugged in. Then I restarted my computer, unplugged the hard drive when it was shutting down. And then when it restarted, I plugged it back in. Waited, but all I got was "Found New Hardware" and it said "USB Root Hub" underneathe, then it said "Your Hardware is now installed and ready to use" then the icon that tells you something is plugged in, disappeared, and there is nothing in "My Computer" apart from the C Drive and the CD Drive (D That's all.

    Any other suggestions?? I just wanna throw it against the wall! Like I said, my wife is not happy right now... it's got all her school work on it, and it's been weeks! Needless to say, she's had to rewrite the essays and all that and I keep getting that evil glare... I would do anything to make it easier for her, and make her happy!

    So any help is GREATLY appreciated!! Well, anything short of "Take it to the shop for a technician to look at it" because we're short on cash, like everybody else is.

    Thanks, again! :-)

  9. #9
    FLAC Trooper ArcticFox's Avatar
    Join Date
    Jan 2003
    Location
    A theater near you
    Posts
    5,424
    The HD in question seems to be this:
    http://www.icecat.biz/en/p/Philips/SPE3051CC|00/Easy%20storage%20extension%20Designed%20to%20store ,%20share%20and%20protect.htm

    with a couple comments about it not showing up. Your PC is a Toshiba, I'm going to assume it's a laptop because I highly doubt your system is a desktop from them seeing that they quit making desktops at the end of 2001 or so.

    If you have a desktop PC handy, or have another drive-less USB enclosure, is that Philips unit one that you can open somehow? The small PCB with the USB bridge chip and power connectors inside it might have gotten damaged, so see if you can wrangle the actual drive out of it's shell and connect it another way.

  10. #10
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    Yeah, that's the hard drive in question :-)
    And yes, it is a laptop. I'm trying to remember when my wife got the laptop... she got it before we met... So about 4 years old, I think?
    And unfortunately, I don't have a desktop handy. No one I really know has a desktop, apart from my sister and brother, but they're 4,000 miles away in Canada.
    But would getting one of those shell's where you can put in an internal hard drive and plug it in like an external hard drive, work at all? That just came to my mind. My mom was talking about it, because she needed one, and suggested me to get one for when I get my internal one shipped from Canada. So would that work at all? If I can take the shell of this one and into the other one?

    Thanks!

  11. #11
    FLAC Trooper ArcticFox's Avatar
    Join Date
    Jan 2003
    Location
    A theater near you
    Posts
    5,424
    Shouldn't be a problem to get an off-the-shelf IDE enclosure, swap the drive into it (assuming, that is, you can open up your Philips case) and try that. If the drive still doesn't work, there is a very slight chance it just doesn't like any other external case except for the one it's meant for but being that it's a Philips and not some kooky proprietary brand I really doubt it will be a problem.

    I've swapped numerous drives out of an Iomega NAS box and that's worked fine, and that's got more wierdness than what you have.

  12. #12
    Junior Member
    Join Date
    Sep 2009
    Posts
    8
    Alright great... I've ran the idea past my wife, but she's at work, so she hasn't got back to me. It'll be a lot cheaper than paying for a technician to pay for it... I really hope it'll work, it'll make my wife happy! LMFAO!!

    I've looked at a computer store, and a cheap one is 20, so that's not bad... I think...

    Thanks, I'll let you guys know if it works (if I get it today) if not, I'll be back on here moaning. And probably just come to the conclusion that it's ruined...

  13. #13
    Junior Member
    Join Date
    Sep 2009
    Posts
    1
    May be you should try the harddrive with some other computer. If that does not work try changing the connecting cable.

  14. #14
    Junior Member
    Join Date
    Nov 2010
    Posts
    1

    Thumbs up Thank you!!!

    Quote Originally Posted by MD1032 View Post
    While it's plugged in, go into device manager (Control Panel, System, Hardware Tab), and right click on the hard drive (might be under unknown devices...the yellow question mark), and just uninstall it. Unplug the drive, restart your computer, and plug it in again. This will give it a chance to completely reinitialize.
    Thanks a ton!!! i did what u said and uninstalled it and now it works again!!!!! My 1 gig external hard drive just stopped working, which has happend to me before with my other hard drive, so i was annoyed to say the least. And when I was plugging my hard drive in it was making nothing work, like my computer would not let me right click it and click manage with the hard drive plugged in, or safely remove hardware would do nothing when i double clicked it, but when i unplugged the hard drive all the stuff would THEN come up.... Anyways just thought it would be nice to say thanks for the help !!!!!!!!!!!!! ! !! ! !! ! nice to have my movies back watching them on the ps3, im going to get my other 500 gig hard drive and do this exact same thing and see if it works thanks again!

  15. #15
    Ultimate Member quickoldcar's Avatar
    Join Date
    Oct 2004
    Location
    NE Pennsylvania
    Posts
    1,005
    Blog Entries
    1
    Just for the record, I've never in my life used "Safely Remove Hardware" in the task bar, except for one time to see what it did.

    I see no reason to do this, I unplug and plug in stuff all the time and always works the same when I reboot.

    And this is a guy that's been with computers since was age 8, so 31 years of fussing with computers I have in me.
    DynaIndex.com - Dynamic search index of websites, links, feeds, title, description, keywords and thumbnail snapshot.

Quick Reply Quick Reply

If you are already a member, please login above.

What is the color of the sky?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AcomData USB 2 External Hard Drive Not Working
    By guyveraxe in forum Technical Support
    Replies: 9
    Last Post: July 23rd, 2010, 02:46 AM
  2. External hard drive stopped working?
    By endrien in forum Technical Support
    Replies: 7
    Last Post: March 14th, 2009, 02:42 PM
  3. Maxtor External Hard Drive is suddenly gone!! HELP!
    By Renchr in forum Technical Support
    Replies: 5
    Last Post: December 31st, 2008, 10:24 PM
  4. Maxtor 5000DV external hard drive not working
    By Terminal23 in forum Technical Support
    Replies: 1
    Last Post: July 28th, 2005, 12:02 AM
  5. Maxtor 80B external hard drive not working
    By DonnaMarilyn in forum Technical Support
    Replies: 6
    Last Post: June 12th, 2005, 02:03 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc