+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    1

    Acer AL2216W frequently will flash logo on and off on startup

    My Acer AL 2216W widescreen LCD monitor has begun exhibiting a very annoying behaviour. When I turn on my computer, the Acer logo displays, then the screen flashes and turns off, as does the green LED on the power switch. Then the Acer logo displays again and the cycle repeats indefinitely. I often have to restart the computer numerous times before the display operates normally. Any suggestions?

  2. #2
    Millwright stroyal's Avatar
    Join Date
    Dec 2002
    Location
    New Hampshire
    Posts
    8,189
    Hi. Welcome to TechIMO!

    What makes you think it is the monitor?
    Problems like this are rarely the monitor, although it is possible.

    Most computer diagnosis is simply a matter of substituting parts.
    Try your monitor, on another computer.
    If it works, it is probably the computer.
    You can further test by trying another monitor on your computer.
    Hard Sayin Not Knowin

  3. #3
    Junior Member
    Join Date
    Sep 2010
    Posts
    2

    Exclamation Verified as monitor issue

    Quote Originally Posted by stroyal View Post
    What makes you think it is the monitor?
    Problems like this are rarely the monitor, although it is possible.
    I was searching for the exact same issue and found this thread. I can verify that it is a monitor issue at least in my case as I have multiple monitors and was able to test substitution.

    Essentially the issue is that whenever the monitor turns off or goes into standby, it struggles to come back on. For instance, in the morning after the screen signal has turned off (or also during reboots, etc.), I'll move the mouse to bring back the screen signal and the AL2216W's indicator light goes from orange to green and the ACER logo displays as it detects the signal. The indicator light then turns off and the screen goes dark. This cycle continues through several times (~10 or so before it actually catches and turns on), with the indicator turning green, the acer splash appearing, and then it all falling off again. Once on, however, it stays on and performs well, but getting on is the struggle. With the other monitor, normal behavior is exhibited.

    When searching for more information about this problem, I came across an AL2216W power supply repair kit that consists of 7 electrolytic capacitors. It doesn't describe what issues would call for it, but dying capacitors seems like a possible explanation. I am comfortable safely de-charging capacitors and de-soldering and soldering on a circuit board, and the $14 price sure beats a new AL2216W at $500+, so does anyone know if this is a common repair for this model or perhaps specifically this issue?

    Repair kit link:
    Corporate Computer

  4. #4
    Junior Member
    Join Date
    Sep 2010
    Posts
    2

    Thumbs up Fixed

    Me again. So I went ahead and ordered the capacitors I described in the previous post and followed the instructions here:
    Repairing the Acer AL2216W LCD monitor : Corporate Computer

    After replacing the capacitors (except for one. I was given a 25v 450 microFarad capacitor but the one I was supposed to replace was a 25v 330 microFarad, so I left the existing capacitor in the board), the monitor is as good as new. It turns on normally and behaves fine.

    Be advised, however, that the soldering connections are quite fine, so the operation isn't for the feint of heart. If it's between that and buying a new monitor, however, may as well give it a shot.

    (Take care to avoid the big 400V capacitor by the power cord, and have a 1000 Ohm or so resistor available for de-charging the capacitors before working on them.)
    Last edited by McDuderson; September 20th, 2010 at 09:09 PM. Reason: unit correction

  5. #5
    Junior Member
    Join Date
    Oct 2010
    Posts
    1

    hey

    im no good techie, how hard was replacing those 7 thingies, cause my monitor is doing the same exact thing. Acer AL2216w
    Last edited by wikkedwhite; October 11th, 2010 at 10:39 PM.

  6. #6
    Junior Member
    Join Date
    Aug 2014
    Posts
    0
    I have that same monitor and same problem. Worked fine for years and started doing this in the past few weeks and seems to be getting slower and slower at coming out of standby. Is there no other solution because I am not going to start replacing individual electronic components. I use the monitor with a PC and Windows XP. Thanks.

Quick Reply Quick Reply

If you are already a member, please login above.

What planet do we live on?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Acer AL2216W Monitor Color Issue
    By kesenn in forum Technical Support
    Replies: 1
    Last Post: December 9th, 2008, 07:03 PM
  2. Acer Al2216W monitor appears to be broken.
    By someoney3000 in forum Graphics Cards and Displays
    Replies: 11
    Last Post: November 14th, 2008, 02:53 PM
  3. ACER e360 Mobo flash?
    By rabidaardvark in forum Motherboards
    Replies: 9
    Last Post: October 3rd, 2008, 09:48 AM
  4. W2K New install stays at startup logo
    By xgabing in forum Technical Support
    Replies: 2
    Last Post: April 28th, 2004, 02:33 PM
  5. How to Remove Mobo logo on startup?
    By thegladiatorgy in forum Technical Support
    Replies: 6
    Last Post: January 26th, 2004, 01:27 AM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc