+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    nit
    nit is offline
    Junior Member
    Join Date
    Nov 2003
    Location
    Oakley, CA
    Posts
    2

    z680 volume problem

    Hey everyone, i'm relativily new to these forums. I have just recently purchashed the logitech z680 speakers from newegg.com. The speakers are pretty loud in stereo and music. The problem i'm having though, is for movies the volume is very low. No matter what input i'm using it is very low. Even when maxing out the control pod and turning up the volume all the way on my nforce it's not very loud. I switched it through prologic, dolby digitial and tried dts movies and it's still not loud. I've tried other sound cards such as the Sound Blaster Live! (non 5.1) and the Game Theatre XP and they all have the effect. I bought a coax cable and ran that through the nforce and game theater and still to no avail, it wasn't boosted. I'm wondering if anyone else has this problem, could my speakers be defective somehow? Am I missing something? If you need more info or anything relative to help me i'll be glad to give it.

    Thanks

  2. #2
    nit
    nit is offline
    Junior Member
    Join Date
    Nov 2003
    Location
    Oakley, CA
    Posts
    2
    BTW I'm using PowerDvd 4.0 on Win xp

Quick Reply Quick Reply

If you are already a member, please login above.

What planet do we live on?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc