+ Reply to Thread
Results 1 to 12 of 12
  1. #1

    HDD recognized in BIOS - Not in Windows

    Greetings Tekkies,

    New Mission: Fix HDD recognition problem with TriGem Imperial GL_VE


    - Board from eMachines T2245 aka TriGem Imperial GL_VE (see info below)

    - CPU = 2.2GHz Celeron

    - OS = Win2000, sp4


    When this board came into my possession it was loaded with a PhoenixBIOS ver. 1.08 (2001) It would recognize HDD's 15GB or below. Anything larger than that, say a 20Gb, 30Gb or 80Gb attached to the primary IDE, as Master or Slave, would not be recognized in the CMOS setup, and even more fun, if one was attached as slave to the Primary IDE and a smaller and recognized HDD attached to the Primary as Master, BOTH HDD's would disappear.

    I thought perhaps that the board might just need an updated BIOS Flash.


    Trying to locate the proper Flash was a real quest. eMachines has a pretty much useless website when it comes to manual and BIOS information. Looking at what was generally out there for the TriGem Imperial GL_VE gives you one flash utility which is completely in Korean and therefore potentially very dangerous. The other utility, Imperial 313, didn't seem to do anything other than to load PhoenixBIOS ver. 1.08, which was what was already loaded.

    The eMachines Upgraders website offered up sp23989.exe (2003), which is a Windows-based upgrade utility. It seemed to work without incident (after loading MSVPC60.dll) until rebooting, which resulted in a blackscreen NTLDR MISSING error, which could not be remedied by an FDISK /MBR or SYS C: restore.

    I ended up reformatting the drive and reloading Win2000, which brought the board back to life.


    Even after doing all this to flash the board and bring it up to a PhoenixBIOS ver 4.00 it still would not recognize anything but smaller-capacity drives attached to the Primary IDE.

    And still, if you attempted to attach a larger drive anywhere on the IDE, what was already recognized would disappear.

    Stepping back and attaching a 15GB or smaller HDD, jumpered as Slave on IDE0, WOULD be recognized in BIOS SETUP, but once booted up into Windows, it remained unrecognized and the Hardware Wizard would not recognize it as well.

    Oddly enough, the Board DOES recognize an external USB 160Gb HDD without problem.


    This is a very odd problem. Any constructive ideas for a remedy?

    Thanks in advance.

    -- KJ


    E-Machines website





    Also HP/ComPaq


    This Model Has HP / Compaq Bios "
    OEM Model Number: 100614 100612 100979 312812
    (NOTE that you could also try searching using a simlar
    emachines mboard model number on your own mboard)

    "This Model Has HP / Compaq Bios " $90

    NOTE that the Trigem mboards can have many different brand name bios versions. I advise you to buy one with an emachines bios version. A mboard with a different
    brand's bios version will work fine, but you may have problems if you ever need to restore the original emachines software if the restore looks for an emachines bios version and doesn't find one. You could flash the bios to an emachines version using the downloads and info on the emachines-upgraders site, or use bios updates if any are available on the www.emachines.com for your model, but flashing a bios is always a risk and you can end up with a mboard that will not boot after you flash.

    EMachines Imperial GV and GLVE Pentium 4 Intel 845GV Chipset Motherboard. Direct Replacement For eMachines T2542, T2596, T2642, T2682, T2692, T2792, T2882, W2646


    OEM Model Number: 100614 100612 100979 312812

    *Please Note: This Model Has HP / Compaq Bios And Can Be Used As A Direct Replacement In eMachines As Well As HP / Compaq PCs.

    Manufacturer Name: eMachines Imperial GV and Imperial GLVE
    CPU/Processor: Socket: 478
    Supports Intel Pentium4 processor

    Front-side bus (FSB): 533/400 MHz

    Chipset Northbridge: Intel 845GV Graphics and Memory
    Controller Hub (GMCH)
    Southbridge: Intel ICH4

    BIOS features: 4 Mb FWH EEPROM
    Award BIOS with enhanced ACPI, DMI, Green, and PnP
    Features Plus

    Form factor: Micro-ATX form factor, 9.6 in x 8.6 in

    Memory: 2 x 184-pin DDR DIMM sockets support
    unbuffered non-ECC 2 GB 333/266 MHz DDR SDRAM memory

    Expansion slots: Three PCI
    No AGP slot

    Video graphics: Integrated

    Onboard audio or audio card: Controller: AC-97
    Realtek ALC650/658 6-channel CODEC chipset
    Dolby 5.1 audio support
    Location: Integrated
    Onboard LAN: Realtek RTL8100C
    10/100 Mbps LAN controller

    Back panel I/O: One PS/2 mouse port
    One PS/2 keyboard port
    One VGA (monitor)
    One Parallel
    One serial port
    Four USB (2.0)
    One RJ45 networking port
    Three audio connectors: line in, line out, and

    Internal connectors: One Primary IDE connector
    One Secondary IDE connector
    One Floppy disk drive connector
    One 20-pin ATX power connector
    One 4-pin ATX 12V power connector
    One USB 2.0 connector supports two additional USB 2.0
    One CPU fan connector
    One Chassis fan connector
    One CD in connector
    One AUX connector
    Front panel audio connector
    System panel connector

  2. #2
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Northern New Jersey
    Are these drives Western Digital?
    MCSE, MCP and nut job

  3. #3
    I got this #43 fan's Avatar
    Join Date
    Mar 2005
    Possibly you could get a new motherboard.
    Otherwise yes, it sounds like an outdated BIOS.

  4. #4
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Northern New Jersey
    To clarify my WD question, they require rather odd jumpering. If the drive is alone on a cable, never jumper them as master. Instead, either remove the jumper or use Cable Select. If you don't, you may get all kinds of weird results.
    MCSE, MCP and nut job

  5. #5
    Hello Bill,

    It is a wide variety of drives that the behaviour has been consistent with, but currently I have a TriGem 15Gb as Master on the Primary and mostly WD's as slave on the Secondary. Thanks for the reminder of WDs' odd jumpering. With them it's usually -- like English Leather -- J50 (on = Master) or nothing at all. Even so, how come attaching a larger-than-15Gb results in ALL drives on the IDE being lost to BIOS?

    Very curious.

    And thank you Captain Obvious for the suggestion to buy a new board.

    I could resolve ALL my minor repair problems, including the wife, with the Captain Obvious throw-it-away-and-buy-a-new-one method.


  6. #6
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Northern New Jersey
    Motherboards of the vintage that supports 2.2GHz Celerons shouldn't have severe drive size limitations in BIOS. These motherboards are no older than 7 years (Man, has it really been 7 years since XP was released? Time flies). You have to go back to 1997 to find motherboards that don't support 128GB.

    No - this is a severe motherboard problem and an aberration. I hate to admit it, but #43 may end up having the last word on this.

    Have you tried clearing CMOS? I would do that before updating BIOS and again after updating same. Clearing CMOS is an A+ requisite after a BIOS update.

    I would also consider new ribbon cables and I would check the motherboard IDE socket for bent or collapsed pins.
    MCSE, MCP and nut job

  7. #7
    Here's an added tidbit: Someone on the eMachines-Upgraders website was kind enough to post the Engrish Translation of the Korean BIOS frashing instructions. It helps if you read it aloud, trying to sound droid-like or extremely Asian.

    Heh heh.

  8. #8
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Northern New Jersey
    Last edited by BipolarBill; May 10th, 2008 at 02:31 PM.
    MCSE, MCP and nut job

  9. #9
    Ummmmm (sounding like Homer Simpson):

    in Cole Slawwwwwww

  10. #10

    You owe me a new screen and keyboard, since I spewed coffee all over mine after visiting Adult Engrish. Hilarious. They are completely ruined (wipes tear from eye). Yes, I spent some time in Japan and was amazed at the persistently-bad Engrish everywhere. It made for a smile every day.

    And thanks for the Clear CMOS tip and ribbon-cables thingy. I have tried both but will also look very closely to see if there have been signs of IDE Pin-Abuse.




  11. #11
    Ultimate Member BipolarBill's Avatar
    Join Date
    May 2002
    Northern New Jersey
    MCSE, MCP and nut job

  12. #12


    Never did find the reason setup BIOS refused to recognize the larger-capacity drives, however, we did have a minor breakthrough with recognizing a <15Gb Slave HDD on IDE0 ---

    Remember, the symptoms were:

    Primary <15 Gb HDD, jumpered for Master, on end of 80 connector ribbon cable recognized on IDE0 in setup BIOS;

    Second HDD, jumpered for Slave on IDE0, on second position of 80 connector ribbon cable, recognized during POST and in setup BIOS, but NOT recognized by Windows Explorer / File Manager for NT.


    Double-checked Slave drive in DOS /FDISK -- drive NOT formatted!

    Formatted drive.


    Voila -- Slave HDD on IDE0 now recognized in Windows.

    Hope this helps someone at some future date.


Quick Reply Quick Reply

If you are already a member, please login above.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. keyboard not recognized. Windows XP won't boot.
    By brkofdon in forum Technical Support
    Replies: 1
    Last Post: January 22nd, 2007, 08:13 AM
  2. HDD sometimes not recognized
    By JohnnyNapalm in forum PC Hardware
    Replies: 2
    Last Post: December 12th, 2004, 06:36 PM
  3. slave hdd not recognized properly
    By KiLLaJ17 in forum PC Hardware
    Replies: 11
    Last Post: June 6th, 2004, 12:29 AM
  4. Recognizing HDD at POST: HDD firmware of BIOS Problem?
    By Chuckiechan in forum General Tech Discussion
    Replies: 7
    Last Post: January 23rd, 2004, 06:07 PM
  5. HD not being recognized in bios
    By Wombat in forum Technical Support
    Replies: 9
    Last Post: January 16th, 2004, 01:36 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Copyright 2014 All Enthusiast, Inc