+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 29
  1. #1
    Member Wolfegang16's Avatar
    Join Date
    May 2009
    Location
    Pittsburgh
    Posts
    164
    This Windows Media Player Network sharing service is always using like 20 percent of my CPU load. I was wondering how to permanently shut this off as it starts up with the computer, when i go to end the task sometimes it comes back and sometimes it doesnt....

    Even if i go to uninstall Windows Media Player it is not showing up anywhere
    Last edited by RicheemxX; June 14th, 2009 at 06:12 PM.

  2. #2
    Ride 'em Cowboy Steve R Jones's Avatar
    Join Date
    Oct 2001
    Location
    Dallas, TX
    Posts
    12,769
    Guessing that you're using Vista...You should be able to reverse the steps here:

    How do I turn on media sharing?
    1. Click the arrow below the Library tab, and then click Media Sharing.

    2. In the Media Sharing dialog box, select the Share my media to check box.

    3. In the list of devices below the Share my media to check box, select a device.

    4. Do one of the following:

    If you want to share your media with the computer or device you have selected, click Allow.

    If you don't want to share your media with the computer or device you have selected, click Deny.
    "If you can keep your head and remain calm when all those about you are panicking...perhaps you don't fully understand the situation!"

  3. #3
    Member Wolfegang16's Avatar
    Join Date
    May 2009
    Location
    Pittsburgh
    Posts
    164
    Ya sorry i should have posted my OS i am running Windows 7

    There seems not to be a media sharing option under library, even if i go into the advanced features tab there is no option to do media sharing.
    Last edited by Wolfegang16; June 15th, 2009 at 08:01 AM.
    PhenomIIX4 940@3.7GHz -- GTX260@735/1625/1275 -- 4Gig Gskill@5-5-5-15/1066
    My PC

  4. #4
    Ride 'em Cowboy Steve R Jones's Avatar
    Join Date
    Oct 2001
    Location
    Dallas, TX
    Posts
    12,769
    Look in the Windows Help file-> Media Sharing
    "If you can keep your head and remain calm when all those about you are panicking...perhaps you don't fully understand the situation!"

  5. #5
    Member Wolfegang16's Avatar
    Join Date
    May 2009
    Location
    Pittsburgh
    Posts
    164
    This may sound really odd and i may be doing something wrong but even if i go into the help file and type in media sharing nothing will come up on the topic. Could it be windows media center doing this and not windows media player ?
    PhenomIIX4 940@3.7GHz -- GTX260@735/1625/1275 -- 4Gig Gskill@5-5-5-15/1066
    My PC

  6. #6
    Member Wolfegang16's Avatar
    Join Date
    May 2009
    Location
    Pittsburgh
    Posts
    164
    I cant even seem to find a windows media player or media center file to uninstall it, even if i go to add/remove programs it doesnt come up on the list. The program is def installed on the computer but for some reason it seems like its hiding lol.
    PhenomIIX4 940@3.7GHz -- GTX260@735/1625/1275 -- 4Gig Gskill@5-5-5-15/1066
    My PC

  7. #7
    Member Wolfegang16's Avatar
    Join Date
    May 2009
    Location
    Pittsburgh
    Posts
    164
    Is there any other way to uninstall a program ??
    PhenomIIX4 940@3.7GHz -- GTX260@735/1625/1275 -- 4Gig Gskill@5-5-5-15/1066
    My PC

  8. #8
    Junior Member
    Join Date
    Jul 2009
    Posts
    1

    remove from startup

    stop it from starting by typing "msconfig" into the run box, then clicking on the services tab and unchecking the checkbox...then restart your computer

  9. #9
    oBeY SiliconJon's Avatar
    Join Date
    Feb 2003
    Location
    Bethalto, IL
    Posts
    10,646
    Blog Entries
    3
    Perhaps this works:
    • disable Windows Media Player Network Sharing Service using services.msc
    • Set the Registry value: HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\P references\HME
      • DWORD DisableBrowse & DisableDiscovery = 1 and 2 respectively



    Disable Windows Media Player Network Sharing and Configuration application (wmpnscfg.exe)

  10. #10
    Junior Member
    Join Date
    Dec 2009
    Posts
    1
    I'm having the same issue on a brand new install of Windows 7 (64-bit) on a Lenovo T61p notebook. This "Windows Media Player Network Sharing Service" is running around 45 to 50% on my computer.

    Under - Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings > Home or Work - I have Media Streaming = OFF (It was ON) But this did not fix it. Its something else.

    I have an Intel Core 2 Duo @ 2.4 GHz with 4GB of memory.
    Last edited by gwguruman; December 30th, 2009 at 09:43 PM.

  11. #11
    Junior Member
    Join Date
    Jan 2010
    Posts
    1
    I had the exact same problem with windows 7 32 bit this service was eating 30% of my cpu on a pentium IV. It only started happening when I started using Foobar2000 and grew my music collection from 8gigs to 40 gigs. I am sharing my music on a network though.

    What I did was I opened msconfig and under services I disabled windows media player network sharing service by unchecking the box beside it. I didn't even have to restart it stopped it right away.

  12. #12
    Junior Member
    Join Date
    Feb 2010
    Posts
    1

    Thanks

    Quote Originally Posted by SiliconJon View Post
    Perhaps this works:
    • disable Windows Media Player Network Sharing Service using services.msc
    • Set the Registry value: HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\P references\HME
      • DWORD DisableBrowse & DisableDiscovery = 1 and 2 respectively



    Disable Windows Media Player Network Sharing and Configuration application (wmpnscfg.exe)

    The link was very helpful. Thanks, my problems have been fixed. There was also an Office network service that required stopping in the same way.

  13. #13
    Junior Member
    Join Date
    Mar 2010
    Posts
    1

    Uninstalling (or disabling) Windows Media Player

    Windows Media Player is not listed as a program because it is considered a base "media" service to the Windows operating system. Other applications co depend on Windows Media Player in order to function properly.

    To disable it in Win7, go to the program and features panel in control panel, then click "Turn Windows features on or off". In the window that pops up, uncheck "Media Features", hit okay, and reboot.

    If you are disabling Windows Media Player I would suggest disabling all three items under under the Media Features list, and not just disabling Windows Media Player by itself.

    Hope this helps!

  14. #14
    Junior Member
    Join Date
    Mar 2010
    Posts
    1
    Quote Originally Posted by gwguruman View Post
    I'm having the same issue on a brand new install of Windows 7 (64-bit) on a Lenovo T61p notebook. This "Windows Media Player Network Sharing Service" is running around 45 to 50% on my computer.

    Under - Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings > Home or Work - I have Media Streaming = OFF (It was ON) But this did not fix it. Its something else.

    I have an Intel Core 2 Duo @ 2.4 GHz with 4GB of memory.
    Hi

    you need to get to administrative tools in the control panel and then services , know if you browse you will find windows media player network sharing services. now simply right click on it and select properties and then select from dropdown tab (disable)

    i don't know the consequences but this is the way i do.

    Regards,

    Amir

  15. #15
    Junior Member
    Join Date
    Apr 2010
    Posts
    1

    help


  16. #16
    Junior Member
    Join Date
    Apr 2010
    Posts
    1

    Wmpns

    For win 7 just
    -right click on "my Computer"
    -click "manage" from the dropdown menu
    -a warning will appear just click "yes"
    -a window title "computer management" will appear (you may need to log in as the admin to do this)
    -in the middle white space dbl Click "Services and Application"
    -in the same area dbl click "Services"
    you will notice a list of services will appear.
    -sort them by name and scrol down to "Windows Media Player Network Sharing Service"
    -Dbl click it to open its properties window
    under the "general" tab look to "startup type"
    -in that drop down menu selsect "Disabled"
    you may need to stop the process from the Windows Task Manager, you need to click "view processes from all users" inorder to see/stop WMPNS.exe
    -once it is dissabled click "ok" or "apply"
    -Close all Windows
    -Restart.
    END


    PS wmpnetwk.exe the .exe file for the service is located in your program files
    "C:\Program Files\Windows Media Player"

    NOTE: be VERY Carefull in computer managemnt, its an easy way to mess some thing up. also i would NOT recomend deleting wmpnetwk.exe as itself is not disabled and my be nedded by the player for other functions.

    Quote Originally Posted by Wolfegang16 View Post
    Ya sorry i should have posted my OS i am running Windows 7

    There seems not to be a media sharing option under library, even if i go into the advanced features tab there is no option to do media sharing.

  17. #17
    Junior Member
    Join Date
    Sep 2010
    Posts
    1

    Windows Media Player Network Sharing Service

    Quote Originally Posted by SiliconJon View Post
    Perhaps this works:
    • disable Windows Media Player Network Sharing Service using services.msc
    • Set the Registry value: HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\P references\HME
      • DWORD DisableBrowse & DisableDiscovery = 1 and 2 respectively


    Disable Windows Media Player Network Sharing and Configuration application (wmpnscfg.exe)
    Thank you for this info.

    It was exactly what I needed.

    I took me a while to figure out what was going on.

    Radar

  18. #18
    Junior Member
    Join Date
    Oct 2010
    Posts
    1

    disable wmp network sharing.

    I found this a relatively simple process, and my computer knowledge is somewhat basic.

    On win 7, go to control panel - network and sharing centre - change advanced sharing settings - choose media streaming options - show devices on all networks - block all - click ok.

    Although wmpnetwk.exe still shows as a process in task manager it doesn't use any of your cpu.

  19. #19
    Junior Member
    Join Date
    Oct 2010
    Posts
    1
    I had a similar issue, every time the Windows Media Player Network Sharing Device would interfer with torrents.. I'd get the problem that torrents could no longer download because another process was using the program (and 45-50% CPU aswell). I'm using Windows 7 and this is how I shut it down (should anyone be wondering):

    Configuratiescherm --> Systeem en beveiliging --> Systeembeheer --> Component Services --> Services (lokaal) --> Windows Media Player Network Sharing Service (it's in the list) --> Right click, properties, startup type --> Disable.

    I don't know all the english translations I'm afraid.

    EDIT: Too rash reply I see, Mec Man posted the same steps. I'll just leave this on here for dutchies then.
    Last edited by Asgardt; October 22nd, 2010 at 02:27 PM.

  20. #20
    Junior Member
    Join Date
    Dec 2010
    Posts
    1

    Stop wmp network service

    .
    Last edited by ecal90; December 11th, 2010 at 07:51 AM.

Quick Reply Quick Reply

If you are already a member, please login above.

What is 10 and 5 added together?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windows Media Player - Download License - Windows Media Services Plug-Ins
    By frankschechter1 in forum Applications and Operating Systems
    Replies: 1
    Last Post: April 2nd, 2009, 06:12 AM
  2. Using Windows Media Player
    By Ymer in forum Multimedia and Audio
    Replies: 4
    Last Post: August 11th, 2005, 05:48 AM
  3. Windows Media Player, other media players
    By shadowfx in forum Applications and Operating Systems
    Replies: 1
    Last Post: October 28th, 2004, 07:28 AM
  4. WIndows Media Player on my TV
    By Wakeboarder141 in forum Multimedia and Audio
    Replies: 3
    Last Post: July 18th, 2003, 05:47 PM
  5. Windows media player will Not ...
    By barginhunter in forum Applications and Operating Systems
    Replies: 2
    Last Post: December 30th, 2002, 05:31 AM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc