+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Mar 2011
    Posts
    3

    Acer Aspire 5920 issues

    So I have been fixing my own computers for years now and I have encountered a couple problems that I have not encountered and cannot seem to find a solution to anywhere else.

    1.) With battery in, AC power plugged in, or both, my laptop will not turn on when I push the power button. The indicator light for the AC power and the light that the battery is charging/fully charged lights up that I have full battery power, but nothing happens. However if, after pushing the power button, I close the laptop and open it, sometimes several times in a row, it will power on.

    2.) Related to first issue, when I choose to restart the laptop, it will shut down but not power itself up.

    3.) When I close it or use the start menu sleep option or the sleep button, the screen goes black but it does not go to sleep. It seems to freeze up and the power button and other lights remain lit.

    4.) The time and date does not remain constant. Approximately every hour or so, it sets itself back an hour. Sometimes after getting the laptop to turn on it will set itself back to April 26, 2007 at 12:00 am. I have found that this may be a CMOS issue, but not sure how to solve that as I cannot find my CMOS or CMOS battery.

    I have tried several solutions and cannot find a lid switch, so I am thinking it may be electromagnetic or some sort of other switch. Any help with these issues would be greatly appreciated.

    Thank you.

  2. #2
    Junior Member
    Join Date
    Mar 2011
    Posts
    2
    it seems i have the exact same issues with my 5920, it started a week or so ago with the pc clock doing random things, i too suspected the cmos battery (you can just see the connector with ram access panel removed, the connector is just to the right of volume wheel) a total teardown is needed to get the cmos out so i did that and swapped it with a temp battery and found no change. im actually on the laptop now with no cmos installed but still it wont switch on or restart of sleep properly. oddly though i have found that if i hold the power button and rapidly open and close the lid as far down as it will go with my hand still inside and then pull my hand out, close lid and open quickly then it starts up????? very bizarre and yes it works every time i try it were as just pressing the power button on its own does nothing.....
    i am suspecting either a faulty lid switch or mother board and any feedback would be helpful.

    im assuming that the lid switch is a magnet and maybe some interferance is the problem.
    anyway ive had this laptop for several years and its been great, dont want to scrap it and its not worth much so any ideas would be very helpful

  3. #3
    Junior Member
    Join Date
    Mar 2011
    Posts
    2
    update, i have now found that its actually pressure on the laptop that allows it to start up.
    perhaps Spaazztik could try this and see if he has the same result.
    press down on the palm rest just to the right of the track pad and just below the keyboard, whilst pressing down hit the power button and see it yours starts, i will teardown my laptop again later and see if i can see any cause on the mother board.

  4. #4
    Junior Member
    Join Date
    Mar 2011
    Posts
    3
    I tried this and yes it did turn on, but the pressure seemed to work in different places each time. As far as I can tell from disassembling my laptop, there's not much there that could have pressure put on it to turn on. Of course I would probably have to have another look at it as I did not look too closely at it. The replacement CMOS battery that I had did not solve any of my issues. nickstock, have you had any luck in diagnosing this issue?

  5. #5
    Junior Member
    Join Date
    Apr 2011
    Posts
    1

    same for me

    Hi, Just wondering how any of you guys went with this problem, have you found the cause or solution? It seems a very specific problem to the 5920 after looking at a few other posts on the internet and I am having the exact same symptoms i.e. time jumping back to 2007, not pwering off onn shutdown, not powering up after it running perfectly for the last few years.
    Thanks to Nickstock now at least I can power up, yes the pressure thing works!

  6. #6
    Junior Member
    Join Date
    Mar 2011
    Posts
    3
    Unfortunately no cause or solution to the problem yet. I did take my laptop apart and found that whatever the pressure is on, it is underneath some plastic covering on the MOBO. I did not see anything that could have caused it though, unless it's some type of short. If it is a mobo problem however, I guess I will have to attempt to get a new laptop. Hopefully this can get solved soon as I like this laptop.

  7. #7
    Junior Member
    Join Date
    Jun 2011
    Posts
    1

    acer pressure/clock issue

    hi all just read your posts and i am experiencing the exact same problem....if i power down the laptop it will not power up again unless i find the "sweet spot" on the casing which is just to the right of the cursor control pad....i have change my power settings now to allow the laptop to be constantly on (good idea/bad idea ?? ).....the clock still loses time on this power setting causing the Internet connection to drop out....looks like the clock syncs with this function....i have had the laptop looked and they suggest a short but they cant find it......help as i really like this laptop and would like to keep it...jk
    ps this fault occured over nite ???

  8. #8
    Junior Member
    Join Date
    Aug 2011
    Posts
    1

    Acer 5920 fix to power issue

    I have an acer aspire 5920 and i have had all of the same issues. I have found out that my bios has a broken buss line or solder joint. Check you clock when you log back into windows i kept setting my time and noticed that it was resetting to 4-26-2007 which was my laptops manufacture date. After a few weeks of this I took it to a friend with a vac tube and we removed the bios and reseated it. I have had no power related issues. The bios is right under the palm rest where you apply pressure all the time. It causes the boards bios chip to break its solder connection after long term use.

    Another trick we tried on my friends laptop which he picked up off of craigslist for 75 bucks with the same problem was this. we placed the motherboard of the laptop on a cookie sheet and placed just the motherboard in the oven for about 10 mins at 200 degrees and it reflowed the broken solder joint and all was good.

    Most caps have a rating of 108 degrees C. and can withstand the 200 degrees F eaisly. ( Which is arround 96 or 97 degrees C)

    I hope this helps.

    Kahndale
    Last edited by Kahndale; August 5th, 2011 at 09:02 PM.

  9. #9
    Junior Member
    Join Date
    Jan 2012
    Posts
    1

    Cool Acer 5920 Clock and power prob

    Yep, same problems here too - any other solutions?

  10. #10
    Junior Member
    Join Date
    Nov 2012
    Posts
    1

    Re: Acer 5920 Clock and power prob

    I had the same issues, time skew and the inability to power the system on without applying pressure to the right of the mouse pad. We isolated it to a crystal labeled Y3 to the bottom right of the bios chip. If you apply lateral pressure to this chip it will power on reliably. We re-flowed the solder on this chip and now it works.

Quick Reply Quick Reply

If you are already a member, please login above.

What is 10 and 5 added together?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. subwoofer in acer 5920
    By yoyoacer in forum Technical Support
    Replies: 1
    Last Post: January 22nd, 2010, 07:30 AM
  2. No Boot After Password on Acer Aspire 5920
    By railfrog in forum Mobile Computing
    Replies: 2
    Last Post: December 31st, 2009, 01:54 PM
  3. Acer aspire - screen resolution issues
    By gius in forum Technical Support
    Replies: 0
    Last Post: July 15th, 2009, 04:18 PM
  4. Acer 5920 Bios problem
    By saksh5 in forum Motherboards
    Replies: 0
    Last Post: June 25th, 2009, 06:16 AM
  5. acer aspire 1525WLMi or aspire 5610AWLMi
    By ABH83 in forum General Tech Discussion
    Replies: 6
    Last Post: November 24th, 2006, 04:22 PM

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2014 All Enthusiast, Inc